| 1 |
alg |
int |
Cryptographic algorithm |
| 2 |
crit |
[+label] |
Critical headers |
| 3 |
content type |
tstr / uint |
Content type of payload |
| 4 |
kid |
bstr |
Key identifier |
| 5 |
IV |
bstr |
Initialization Vector, see The nonce |
| 6 |
Partial IV |
bstr |
Partial Initialization Vector |
| 15 |
CWT Claims |
map |
CWT claims in the header (RFC 9597), getCwtClaims() |
| 16 |
typ |
tstr / uint |
Type of the COSE object (RFC 9596), getTyp() |
| 11 |
Countersignature version 2 |
COSE_Countersignature / [+ COSE_Countersignature] |
Full countersignatures, unprotected only (RFC 9338), getCountersignatures() |
| 12 |
Countersignature0 version 2 |
bstr |
Abbreviated countersignature, unprotected only (RFC 9338), getCountersignature0() |
| 32 |
x5bag |
COSE_X509 |
Unordered bag of X.509 certificates (RFC 9360), getX5Bag() |
| 33 |
x5chain |
COSE_X509 |
Ordered chain of X.509 certificates, end-entity first (RFC 9360), getX5Chain() |
| 34 |
x5t |
COSE_CertHash |
Thumbprint of the end-entity certificate (RFC 9360), getX5T() |
| 35 |
x5u |
uri |
URI of an X.509 certificate, never fetched by this library (RFC 9360), getX5U() |
| 258 |
payload-hash-alg |
int |
Hash algorithm of the payload of a hash envelope, protected only (RFC 9995), getPayloadHashAlg() |
| 259 |
preimage-content-type |
uint / tstr |
Content type of the hashed bytes, protected only (RFC 9995), getPreimageContentType() |
| 260 |
payload-location |
tstr |
Where the hashed bytes can be retrieved, never fetched by this library (RFC 9995), getPayloadLocation() |
| 394 |
receipts |
[+ bstr .cbor Receipt] |
COSE receipts, each a tagged COSE_Sign1 (RFC 9942), getReceipts() |
| 395 |
vds |
int |
Verifiable data structure of a receipt, protected bucket only (RFC 9942), getVds() |
| 396 |
vdp |
map |
Verifiable data structure proofs of a receipt, keyed by proof type (RFC 9942), getVdp() |